Jump to content


Photo

Pro-mo Build Clutch Advice


  • Please log in to reply
2 replies to this topic

#1 YIANO

YIANO

    Mini Mad

  • Members
  • PipPipPipPip
  • 210 posts

Posted 01 February 2009 - 11:26 PM

hi guys , today i hooked up the clutch an slave and bled the sytem , my question is regarding pedal travel ,is it supposed to have a very short pedal throw?
the pedal only goes down about an inch or so is this normal or am i missing something ?
thanks
jon

#2 Basky

Basky

    Mini Mad

  • Members
  • PipPipPipPip
  • 265 posts

Posted 01 February 2009 - 11:49 PM

hi guys , today i hooked up the clutch an slave and bled the sytem , my question is regarding pedal travel ,is it supposed to have a very short pedal throw?
the pedal only goes down about an inch or so is this normal or am i missing something ?
thanks
jon


AUP Jon

Well first things first (probably already done this) just check nothing is snagging etc! i have full travel as you are supposed to have as it is a normal mini setup after all pedal master & salve! then just check if you have the clutch arm in the correct position and isn't hitting the aperture in the suby!

then if all this is correct then you might have to take the master off & have a look at that! Replace or repair?!?!

All the best

#3 YIANO

YIANO

    Mini Mad

  • Members
  • PipPipPipPip
  • 210 posts

Posted 02 February 2009 - 12:46 AM

its probably the clutch arm position then as the clutch slave cylinder is new.
so to recap, the arm should be at 45 deg at rest pointing to the large bolt holding the upper engine cradle, then pushed forwards towards the front of the car to disengage the clutch during pedal stroke downwards ?

thanks basky




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Mini Spares