Jump to content


Photo

My Pro-Motive Adventure.... This Could Be Interesting!


  • Please log in to reply
97 replies to this topic

#31 duds100

duds100

    Mini Mad

  • Members
  • PipPipPipPip
  • 227 posts
  • Location: Warwickshire

Posted 12 July 2013 - 11:15 AM

Well my painter is a little bit tied up with other things so I decided to use a rusty clubby I have as a mule to make sure its all is as it should be...
IMAG0639_zps99eb91b1.jpg

Now the fun wiring! Yay!

I hope to have it fired up next week. On a side note where and how have people sorted the fuel return? Back to tank or just back inline?

Build is looking good! looks like a 5PW injection motor to me, the same as I am running. Fuel return I have run all the way back to my ally tank in the rear. The fuel really flies back to the tank at engine idle (i`m using an electric V8 TVR bosch injection pump, not the R1 pump). You could do the same or use an MPI mini tank and fuel pump, but again I would run the fuel return back to the tank.



#32 domdee

domdee

    Formally known as dominicdee

  • Members
  • PipPipPipPipPipPipPip
  • 1,182 posts
  • Location: hull
  • Local Club: hull clubs on FB

Posted 12 July 2013 - 11:41 AM

nice build

good to see zcars alternatives



#33 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 13 July 2013 - 12:10 PM

Which side is fuel into the rail if looking at the above picture?

#34 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 14 July 2013 - 03:05 PM

Well managed to do the wiring and get it turning over on the key, after figuring out I needed to supply power to the mini too! Lol... Deer....

Still plenty to do to get it drivable for a shack down, fuel piping, brakes and cooling to name but a few!

#35 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 15 July 2013 - 02:45 PM

More progress...

 

well on the mock up body test rig!

 

Managed to make it run on a drink or juice as awaiting my fuel pump. Has everyone returned into the tank or plumbed back in tank side of the pump?

 

ps. Sounded like a beast without the exhaust on!



#36 racerlike

racerlike

    Speeding Along Now

  • Members
  • PipPipPipPipPip
  • 393 posts

Posted 15 July 2013 - 03:07 PM

As someone mentioned above an Mpi tank is the simplest solution. That's what I have done and the fuel returns directly to the tank

#37 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 18 July 2013 - 01:36 PM

It lives.... Started and running! Sounds fun!

#38 kjwithers

kjwithers

    Stage One Kit Fitted

  • TMF+ Member
  • PipPipPip
  • 61 posts
  • Location: Somerset

Posted 19 July 2013 - 05:52 PM

Video??!!

#39 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 22 July 2013 - 01:00 PM


[ur] [/url]

Edited by blunder, 22 July 2013 - 02:09 PM.


#40 kjwithers

kjwithers

    Stage One Kit Fitted

  • TMF+ Member
  • PipPipPip
  • 61 posts
  • Location: Somerset

Posted 22 July 2013 - 04:28 PM

Awwwsome, sounds great!

#41 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 27 July 2013 - 11:38 AM

Ok... It starts it runs and have driven around the block.... I seems a little hesitant and jerky on throttle.... This usual? Also not overly great to start? Maybe that's a fuel pump thing? But not the smooth at idle either are they constant or wander in the revs a little?

#42 clovus

clovus

    Mini Mad

  • Members
  • PipPipPipPip
  • 231 posts
  • Location: Down under

Posted 28 July 2013 - 03:14 AM

Good work mate. Will be really keen to hear how it drives once you're all sorted.

#43 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 28 July 2013 - 11:38 AM

Think I may need to get the throttle bodies balanced/checked and probably need to check the vac pipes make sure they are all hooked up...

Read up this can cause rough idle like I have, anyone have any experience of this?

Drove it today though..... Goes like s&*t off a shovel! Lol

#44 blunder

blunder

    Mini Mad

  • Noobies
  • PipPipPipPip
  • 113 posts
  • Location: Perth

Posted 01 August 2013 - 01:28 AM

Question for the guys running this set up.... What height off the ground is your sump?

#45 racerlike

racerlike

    Speeding Along Now

  • Members
  • PipPipPipPipPip
  • 393 posts

Posted 01 August 2013 - 02:40 PM

I'm on 10" wheels and the sump is about 3.5 - 4" from the deck.
Worryingly low if I'm honest.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares