Jump to content


Photo
- - - - -

Loss Of Power


  • Please log in to reply
11 replies to this topic

#1 Chesty2925

Chesty2925

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 83 posts
  • Location: Essex

Posted 07 May 2018 - 02:24 PM

Hi my mini starts up ok and we went on a drive. Then on the drive it backfired like it had dirty fuel and then continued to run. Then on a hill it cut out. I managed to start it again and get it to the side of the road. It still starts but when I try to move it in gear it dies and cuts out. Any ideas??

#2 Chesty2925

Chesty2925

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 83 posts
  • Location: Essex

Posted 07 May 2018 - 05:49 PM

I left it for a few hours and then when I went back to it, it started fine and ran ok all the way home.

#3 Moke Spider

Moke Spider

    Crazy About Mini's

  • TMF Team
  • PipPipPipPipPipPipPipPipPipPip
  • 7,587 posts
  • Location: NSW
  • Local Club: South Australian Moke Club

Posted 07 May 2018 - 07:27 PM

It does have a fuel pump or blocked fuel filter (for fuel line) sound about it.



#4 Icey

Icey

    One Carb Or Two?

  • Traders
  • PipPipPipPipPipPipPip
  • 996 posts
  • Location: Wiltshire

Posted 07 May 2018 - 07:35 PM

I was thinking more a failing coil what with the heat weve had this weekend.

Edited by Icey, 07 May 2018 - 07:35 PM.


#5 Aaron3

Aaron3

    Mini Mad

  • Members
  • PipPipPipPip
  • 158 posts
  • Location: Warrington

Posted 07 May 2018 - 07:55 PM

Could be dirt in the bottom of the float chamber, that usually lets them idle but not accelerate as it restricts the fuel to the jet

#6 Chesty2925

Chesty2925

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 83 posts
  • Location: Essex

Posted 07 May 2018 - 09:01 PM

I will try and diagnose the problem. Thanks though. Could it be due to the fuel sitting in the tank for 6 months? It was my first run out in the mini since last year

#7 Tda321

Tda321

    Learner Driver

  • TMF+ Member
  • PipPip
  • 18 posts
  • Location: Driffield, East Yorkshire

Posted 07 May 2018 - 09:15 PM

Could well be. The fuel on my Dad's mower went stale over this winter!

Edited by Tda321, 07 May 2018 - 09:19 PM.


#8 absx2

absx2

    Speeding Along Now

  • Members
  • PipPipPipPipPip
  • 373 posts

Posted 08 May 2018 - 06:46 AM

If your ignition is the points and condenser I would also change the condenser as they break down with heat but run fine when cooled down again.

 

As above blockage or old fuel especially with a heated cast inlet manifold to kill off whats left of the octane level. 


Edited by absx2, 08 May 2018 - 06:47 AM.


#9 andyapanel

andyapanel

    Mini Mad

  • Members
  • PipPipPipPip
  • 192 posts

Posted 08 May 2018 - 07:02 AM

Sounds like the Coil to me.



#10 ings

ings

    Mini Mad

  • TMF+ Member
  • PipPipPipPip
  • 133 posts
  • Location: ZH

Posted 08 May 2018 - 07:36 AM

an electronic dizzy can make a huge change...



#11 Chesty2925

Chesty2925

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 83 posts
  • Location: Essex

Posted 08 May 2018 - 08:16 AM

Whats the best way to test the coil or dizzy? Or just replace them both?

#12 Chesty2925

Chesty2925

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 83 posts
  • Location: Essex

Posted 13 May 2018 - 04:06 PM

Update. I stuck some slick 50 in and gave her a run with high revs. Then filled her with petrol. All good no prI blend. Fingers crossed I get to Brighton ok next week.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares