Jump to content


Photo

Help! Jump Started Mpi Wrong Way Around.


Best Answer Homersimpson , 06 June 2018 - 12:19 PM

If you connected it backwards and then connected it the right way around some items may be damaged, however, other things like the lights should still work. 

 

If you have literally nothing then it sounds like either your jump battery is flat, not connect properly or your old battery is causing a dead short (you would have had huge sparks when you connected the jump cables to it if this were the case) and needs to be removed from circuit.

Go to the full post


  • Please log in to reply
1 reply to this topic

#1 hsular

hsular

    Just On Tickover

  • Noobies
  • Pip
  • 9 posts
  • Location: Harlow

Posted 06 June 2018 - 12:07 PM

Hi folks,

 

I was trying to jump the car but I have connected it the wrong way around. No smell or nothing came but the car is dead unfortunately. I have checked every visible fuse under the bonnet and in the cockpit but all fine. Also I have tried extra ground to see if it is ground but it is the same thing again. Is there any hidden fuse somewhere that I can not see or is it the ECU burned?

 

The car is 96 MPI.

 

Your help is appreciated.

 



#2 Homersimpson

Homersimpson

    Mini Mad

  • Members
  • PipPipPipPip
  • 164 posts
  • Location: Redditch

Posted 06 June 2018 - 12:19 PM   Best Answer

If you connected it backwards and then connected it the right way around some items may be damaged, however, other things like the lights should still work. 

 

If you have literally nothing then it sounds like either your jump battery is flat, not connect properly or your old battery is causing a dead short (you would have had huge sparks when you connected the jump cables to it if this were the case) and needs to be removed from circuit.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares