Jump to content


Photo

Clutch And Brake Issues


  • Please log in to reply
1 reply to this topic

#1 muller295

muller295

    On The Road

  • Noobies
  • PipPip
  • 40 posts
  • Location: Holland

Posted 07 August 2018 - 09:56 AM

Hi,
Lately I have been having some problems with both my brakes and my clutch. After completely rebuilding my front calipers there is something wrong with the braking pedal, as it does not come back up all the way after pressing it, so after pressing the brakes, the braking lights stay on. I can not imagine it being air trapped in the system as I have bleeded it a few times now with an eezibleed. The braking system is not leaking fluid.

Other than that, my clutch master cylinder was leaking, so I decided to rebuild it. After reassembly and bleeding it, the pedal feels lighter than before, and there is fluid leaking from the overflow on the filler cap. I did buy a new cap, so what could be the problem here?

Thanks in advance!
Sander

#2 richardtrivella

richardtrivella

    Passed Test

  • TMF+ Member
  • PipPip
  • 31 posts
  • Location: Banbury
  • Local Club: NA intrested though?

Posted 12 August 2018 - 08:45 PM

hi,

im not sure how much this is actually going to help but anyway....

to start with just to be sure these no leak have you pumped the brake a load of times and check that the brake fluid hasn't reduced in height in the reservoir?

if its not a leak or air in the system maybe you have an issue with the vacuum servo unit? I could really tell you how to check this or if that is a legitimate reason for the brake pedal but hopefully, someone else on here could answer that.  






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares