Jump to content


Photo

Oil Pressure Mpi


  • Please log in to reply
3 replies to this topic

#1 Glenny1481

Glenny1481

    On The Road

  • Noobies
  • PipPip
  • 37 posts
  • Location: Edinburgh

Posted 15 March 2019 - 10:48 PM

My oil pressure light started to flicker when I stopped at lights the other day, but when I revved above 1.2k revs it went off, I got home as it was less than a mile and turned it off. Oil level is fine and just put a new oil pressure switch in as had one spare sitting there, that didn’t fix it. It doesn’t flicker until the engines hot.

Is there anything that is specifically bad for going?

What is likely to be damaged due to the low pressure?

Thanks

#2 nicklouse

nicklouse

    Moved Into The Garage

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPipPipPip
  • 11,546 posts
  • Location: Not Yorkshire
  • Local Club: Anonyme Miniholiker

Posted 15 March 2019 - 11:01 PM

sounds like time for a rebuild.

but first clean out the pressure relief valve and see if that fixes it as it may not be closing.



#3 Glenny1481

Glenny1481

    On The Road

  • Noobies
  • PipPip
  • 37 posts
  • Location: Edinburgh

Posted 16 March 2019 - 06:45 PM

sounds like time for a rebuild.
but first clean out the pressure relief valve and see if that fixes it as it may not be closing.


Runs absolutely fine though, just the light comes on

#4 Steve220

Steve220

    Up Into Fourth

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 3,531 posts
  • Location: Shropshire
  • Local Club: RAF Mini Club

Posted 16 March 2019 - 07:05 PM

Remove the pressure relief valve cover and see if the plunger moves freely and isn't stuck.




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

Mini Spares