Jump to content


Photo
- - - - -

Running On Two Cylinders


  • Please log in to reply
4 replies to this topic

#1 maccers

maccers

    Camshaft & Stage Two Head

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,679 posts
  • Location: Epsom
  • Local Club: LSMOC

Posted 13 May 2019 - 08:47 PM

Have a custom fuel injection based engine, uses coil pack wasted spark system, started car for first time in a few months, sounded a bit rough, pulled off leads one by one. Middle two firing, the ones at either end (assume 1 and 4) when pulled make no difference, any of the middle two when pulled off engine stalls.
Plugs are very recent, have had car running on them. Unlikely two leads would fail. Do coil packs fail? What’s the best way to test this? It’s running emerald ecu.

#2 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,620 posts
  • Local Club: www.scottishmini.net

Posted 13 May 2019 - 09:56 PM

I'd say the leads are shot,

Swap the leads about, see if it still runs rubbish it needs leads.

#3 sledgehammer

sledgehammer

    Up Into Fourth

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPip
  • 2,989 posts
  • Location: I'm sittin here besides my self

Posted 13 May 2019 - 10:19 PM

IIRC the wasted spark is 1 & 4 , and 2 & 3 each sharing a coil
 

it's a possibility the coil pack is failing

 

but as above - go with the cheaper things first

 

I also recall talk of a cheaper coil pack doing the same job ?

 

can't remember what car ?


Edited by sledgehammer, 13 May 2019 - 10:57 PM.


#4 maccers

maccers

    Camshaft & Stage Two Head

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,679 posts
  • Location: Epsom
  • Local Club: LSMOC

Posted 14 May 2019 - 04:36 AM

Cheers for that, I do have a spare set of leads. Do they break down through lack of use?

#5 maccers

maccers

    Camshaft & Stage Two Head

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,679 posts
  • Location: Epsom
  • Local Club: LSMOC

Posted 14 May 2019 - 12:47 PM

Changed the leads, no difference, took the plugs out and gave them a good clean up. Looks like its the coil pack, the cylinders not firing are 1 and 4, that seem to be plugged into one bank on the coils. So hopefully its that and I can get a replacement part.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares