Jump to content


Photo
- - - - -

Seatbelt Issues


  • Please log in to reply
7 replies to this topic

#1 finch661

finch661

    Up Into Fourth

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPip
  • 2,313 posts
  • Location: Kirkwall
  • Local Club: none

Posted 14 May 2019 - 07:40 AM

Good morning all  :proud:

Just a quick one regarding seatbealts.  I have a securon inertia seatbelt in the back of my mini, but it isnt working correctly.  It doesnt want to extend, you can slowly extend it by pull it (20+ times), but retracts fine.  A few youtube videos suggested putting the unit in a bucket of soapy water to remove the grime (that could be jamming it).  What is strange is when the unit is in the water, it works fine, but as soon as its out, it jams again.  i get the feeling its due to the ball bearing floating when in water?  any clues, or ideas on how i can strip it down?

 

thanks

 

Rich



#2 unburntfuelinthemorning

unburntfuelinthemorning

    One Carb Or Two?

  • TMF+ Member
  • PipPipPipPipPipPipPip
  • 1,038 posts
  • Location: Bedfordshire

Posted 14 May 2019 - 07:53 AM

Hmm, not sure soaking it in water will be good for it long term.  Maybe just replace the unit as it's quite important that it works correctly.



#3 Junior Mini

Junior Mini

    Mini Mad

  • Members
  • PipPipPipPip
  • 257 posts

Posted 14 May 2019 - 09:03 AM

Has it worked in that fitted position before now? It might be in the wrong orientation?

#4 DeadSquare

DeadSquare

    One Carb Or Two?

  • Members
  • PipPipPipPipPipPipPip
  • 1,267 posts
  • Location: Herefordshire
  • Local Club: Herefordshire Motor Club

Posted 14 May 2019 - 10:47 AM

Good morning all  :proud:

Just a quick one regarding seatbealts.  I have a securon inertia seatbelt in the back of my mini, but it isnt working correctly.  It doesnt want to extend, you can slowly extend it by pull it (20+ times), but retracts fine.  A few youtube videos suggested putting the unit in a bucket of soapy water to remove the grime (that could be jamming it).  What is strange is when the unit is in the water, it works fine, but as soon as its out, it jams again.  i get the feeling its due to the ball bearing floating when in water?  any clues, or ideas on how i can strip it down?

 

thanks

 

Rich

 

 

From your photo, it would seem that you have solved the problem. Keep driving through the water

 

 

4685983050_06a0abe3b2_zpsdmdso7qm.jpg


Edited by DeadSquare, 14 May 2019 - 10:47 AM.


#5 luismx123

luismx123

    Speeding Along Now

  • TMF+ Member
  • PipPipPipPipPip
  • 367 posts
  • Location: Graz

Posted 14 May 2019 - 11:10 AM

uhm, not exactly sure but i had a similar issue with rear inertia seatbelts.

You need to make sure that they are able to be mounted on the C-Pillar. Some inertia rear seatbelts (like the minispares ones I had) only work when mounted flat/horizontal on the rear parcel shelf! If you tilt/twist/lift the mechanism up and away from flat/horizontal, the system doesnt allow the belt to be released!
 

Remove it from the car, hold it flat on the ground and see if it works there. Im not sure, but I really think this could be the issue - if you have one made for the parcel shelf



#6 DeadSquare

DeadSquare

    One Carb Or Two?

  • Members
  • PipPipPipPipPipPipPip
  • 1,267 posts
  • Location: Herefordshire
  • Local Club: Herefordshire Motor Club

Posted 14 May 2019 - 11:59 AM

There are two ways in which the belt can be locked.

 

1)  As the car slows, a ball rolls forward, lifting a pawl which.engages a ratchet on the reel.

 

With this type, the belt can not be extended if the car is on a down hill slope.

 

 

2)  If the belt is jerked, pawls on the reel fly outwards and engage a dog.

 

With this type, the belt can be extended slowly on a slope.



#7 dyshipfakta

dyshipfakta

    One Carb Or Two?

  • Members
  • PipPipPipPipPipPipPip
  • 1,492 posts

Posted 14 May 2019 - 12:50 PM

Orientation is everything with these. They must be perfectly vertical maybe it was knocked out of alignment

#8 finch661

finch661

    Up Into Fourth

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPip
  • 2,313 posts
  • Location: Kirkwall
  • Local Club: none

Posted 14 May 2019 - 01:08 PM

Hi all, thanks for the replies.  It was working correctly, then just stopped.  I have removed the reel and tested it in multiple angles and its the same result (cant extend it).  as said, it only works if the unit is submerged in water.... strange






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares