Jump to content


Photo

Problem With Immobiliser On Rover Mini Cooper Mpi


  • Please log in to reply
3 replies to this topic

#1 scunnyminicooper

scunnyminicooper

    Starting My Mini Up

  • Noobies
  • Pip
  • 1 posts
  • Location: Scunthorpe

Posted 15 May 2019 - 02:39 PM

Help needed please....

 

My mini has been garaged for a few months, battery disconnected. I reconnected and tested the battery this morning, the car started first time and ran fine. Went back to it a few hours later, turned the ignition, dash lights all came on fine, but no engine start! tried to bump start, nothing again. I suspected an immobiliser issue, a mechanic friend suggested disconnecting the battery, shorting the pos and neg leads together to discharge any residual charge in any capacitors etc, leave for 20 minutes and re-connect and try again. Did this, still the same issue, with the exception that there was a slight clicking noise which I am pretty sure was the horn trying to sound as if the alarm was activated.

 

The LED on the dash was not lit at all to alert that the alarm was on. The key fob is doing nothing either, press open or lock, no flashing of the indicators (although they work fine for normal use).

 

checked the key fob batteries and they are not full, but sat at around 2.7v each (there are 2 x CR1220 3V cells in the key fob)

 

has anyone had similar issues?



#2 Itsaminithing

Itsaminithing

    Super Mini Mad

  • Members
  • PipPipPipPipPipPip
  • 607 posts
  • Location: Berkshire
  • Local Club: TVMC

Posted 15 May 2019 - 03:29 PM

If left for too long the MPI immobiliser system & fob seem to lose track of each other.

Got mine to re-sync by repeatedly & rapidly pressing lock untill the indicators flashed....  (i think i then did the same with unlock button but this was years ago so i can't be sure).

Let us know if it works.



#3 hunterg30

hunterg30

    Mini Mad

  • Members
  • PipPipPipPip
  • 275 posts

Posted 15 May 2019 - 03:33 PM

Is the car battery fully charged ? You might have taken the last bit of charge when you started it. If you have the two button fob I think it has to be re tuned to the immobiliser by pressing one of the buttons a couple of times near to your car

#4 dan1zo

dan1zo

    On The Road

  • Noobies
  • PipPip
  • 37 posts
  • Location: Kent

Posted 15 May 2019 - 04:21 PM

Sounds like the battery is a bit dead. Mine did the clicking a while back when i set the alarm off on low charge. No lights flashed and the horn didnt sound but it clicked the relays.

 

When the battery is disconnected, the alarm remembers the last state of the immobiliser. So if it was off it will be off when you reconnect the battery.

You can re-connect the fob if necessary by pressing the unlock button 4-6 times i think. I just keep pressing it until the immobiliser turns off.

 

Hope a good charge sorts it for you.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares