Jump to content


Photo
- - - - -

Poor Running


  • Please log in to reply
2 replies to this topic

#1 grahama

grahama

    Up Into Fourth

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 2,437 posts
  • Location: Warrington
  • Local Club: None in my area !!

Posted 05 August 2019 - 04:28 PM

Hi all,

 

was going to try and MOT the 998 mini this week so put the fuel system in and filled up.  Started well enough but boy it is running rough.

 

Red light on dash wont go out so think its not charging but that's ok for now, 50psi idle revs up to 65psi on oil pressure

 

it sounds like it is struggling to breathe, but sounded the same with the air filter out.  Cant stab the throttle or it nearly dies, have to build up the revs a bit more slowly

 

fresh fuel, tried moving the distributer about to no avail, idles fine but wont rev above 4000rpm and takes a couple of seconds to get to that.

 

points and rotor new although been in the car for a few years.

 

anything I can try before I give in and send it to the garage??

 

just in case, are there any classic garages near warrington??

 

Graham


Edited by grahama, 05 August 2019 - 04:38 PM.


#2 paul748

paul748

    Stage One Kit Fitted

  • TMF+ Member
  • PipPipPip
  • 74 posts
  • Location: Yorkshire

Posted 05 August 2019 - 04:42 PM

Sounds like a carb problem to me.

Make sure the 'choke' is not sticking in the cold start position. 

Also you could remove the intake trumpet, stick your finger into the inlet  O_O  and check that the piston moves up and down without sticking.

Paul



#3 grahama

grahama

    Up Into Fourth

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 2,437 posts
  • Location: Warrington
  • Local Club: None in my area !!

Posted 05 August 2019 - 06:05 PM

The choke isn’t sticking and it looks like the piston is moving up and down when I move the throttle linkage by hand.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares