Jump to content


Photo
- - - - -

Air Filter And Electrical


  • Please log in to reply
10 replies to this topic

#1 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 07 September 2019 - 06:22 PM

Hey
Got my first mini. Currently has no air filter attached , the pipercross one is in the car. The filter has a gasket and a large spacer i assume needs used? But im not sure how to get it fitted as the filter has no built in bolt or nut so i cant work out how to bolt it to carb?

also my wipers, horn and rear fog dont work. Seller says wipers werent working, then came on and couldnt go off then finally worked normally but since delivery no joy. The horn itself is in bits so until i get a replacement cant say for sure of the issue

#2 Ethel

Ethel

    ..is NOT a girl!

  • TMF Team
  • PipPipPipPipPipPipPipPipPipPipPip
  • 22,926 posts
  • Local Club: none

Posted 07 September 2019 - 10:29 PM

Welcome,

 

Some photos might help with the filter, there's usually some sort of fastener(s) holding the filter itself to a backplate that is just screwed to the carb's body before the filter's assembled.

 

The fog light will be fed off the headlight circuit so you need them on too. It's possible you could also need the ignition on.

 

The horn shares a supply with the headlight flasher, if that works it'll narrow down the fault to the stalk, horn or wire between them.

 

If the wipers don't turn off it'll be the park switch on the motor, but you could have another fault as well if they don't work at all.



#3 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 08 September 2019 - 07:05 AM

Hello

Thanks for the reply

I will try and get some photos of filter today.

The fog switch doesnt light up however we did not try this with head light switch on so will try that. We could not get the headligjt flasher to work either

currently my wipers are both up mid screen and i can get them to move at all? If its the park switch wont the wipers come back on after cars been turned on or off?

#4 Norfolk Boy

Norfolk Boy

    Stage One Kit Fitted

  • TMF+ Member
  • PipPipPip
  • 65 posts
  • Location: Norfolk
  • Local Club: Norfolk Mini Owners Club

Posted 08 September 2019 - 08:17 AM

I had a problem with headlight flash also, turned out to be the contact at the end of the stalk, cleaned it up with a bit of emery paper works fine now.

#5 Ethel

Ethel

    ..is NOT a girl!

  • TMF Team
  • PipPipPipPipPipPipPipPipPipPipPip
  • 22,926 posts
  • Local Club: none

Posted 08 September 2019 - 01:43 PM

That's a possibility. The flasher and horn or on a fused permanent live circuit with the interior light, so a fault on any can blow the fuse and stop the lot.

Knowing the wire I'd basics is useful ...

Brown - unfused permanent live

Purple - fused permanent live

White - unfused ignition fed live

Green - fused ignition live

Black - earth

Blue - headlights (unfused on most Minis)

Red - sidelights

They're the basics trace colours give more detail for example blue becomes blue/white for high beam or blue/red to dipped after the headlight stalk.

#6 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 08 September 2019 - 05:06 PM

Interior light does not work also sorry should have said

#7 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,682 posts
  • Local Club: www.scottishmini.net

Posted 08 September 2019 - 05:31 PM

If the interior light doesn't fit check the purple and orange wired inline fuse behind the carb, a quick check is to operate the Hazard lights

#8 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 08 September 2019 - 09:48 PM

indicators work but hazard button does not?

#9 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,682 posts
  • Local Club: www.scottishmini.net

Posted 09 September 2019 - 04:54 PM

Check the fuse that is on the purple/orange wire behind the carb

Edited by cal844, 09 September 2019 - 04:55 PM.


#10 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 10 September 2019 - 09:45 AM

The fuse is fine however may have to trace wire incase of a break
i know wipers were stuck up so that could be park switch and horn i dont think is complete.
So will need to test wiper motor off car and horn also
I want to adjust carb and getting it running good first then start electrics as it will be time consuming and frustrating

#11 Jonesy77

Jonesy77

    Just On Tickover

  • Noobies
  • Pip
  • 8 posts
  • Location: Northern Ireland

Posted 10 September 2019 - 09:47 AM

Also got filter on and car wouldnt start.
spark plugs black so she must be running very rich




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares