Jump to content


Photo
- - - - -

Intermittent Ignition/power Problem


  • Please log in to reply
3 replies to this topic

#1 1314cc

1314cc

    Mini Mad

  • Members
  • PipPipPipPip
  • 181 posts
  • Local Club: tumbleweedminisbristol

Posted 12 September 2019 - 12:09 PM

Ok, so I've new battery, main cable, new earths. The fault first occurred 6 years ago . Mini has been off the road since then. Finally im almost ready for a mot! So im experiencing an occasional complete loss of engine power and ignition lights go out . After grinding to a halt it starts up again. Could this be the ignition switch or the brown wire feeding off it?

Edited by 1314cc, 12 September 2019 - 12:36 PM.


#2 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,682 posts
  • Local Club: www.scottishmini.net

Posted 12 September 2019 - 12:49 PM

The lights should come on when power is off. Check and clean the connections at the fusebox, starter and ignition switch then go from there

#3 viz139

viz139

    Mini Mad

  • Members
  • PipPipPipPip
  • 216 posts
  • Location: Ireland
  • Local Club: Irish Mini Owners Club

Posted 12 September 2019 - 02:46 PM

If your power lose is limited to engine and ignition lights that would suggest the problem is in the white wiring. Wipers ,indicators ,horn hazards all still working. 

I would first check the ignition switch and the connector at the steering column.

What year is the car?



#4 1314cc

1314cc

    Mini Mad

  • Members
  • PipPipPipPip
  • 181 posts
  • Local Club: tumbleweedminisbristol

Posted 12 September 2019 - 04:37 PM

1989
I'll have to wait for it to occur the next time i've got it running to check the wipers etc .




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares