Jump to content


Photo
- - - - -

Light Issue


  • Please log in to reply
6 replies to this topic

#1 GordonS

GordonS

    Starting My Mini Up

  • Noobies
  • Pip
  • 3 posts
  • Location: Ayrshire

Posted 12 January 2020 - 02:11 AM

I am having an issue with all lights on my car. The headlights, rear lights, dash lights and interior light will not turn on. The car drives ok but the lights aren’t coming on. My car is a 1990 Mini City

#2 MacGyver

MacGyver

    One Carb Or Two?

  • Members
  • PipPipPipPipPipPipPip
  • 756 posts
  • Location: Fribourg

Posted 12 January 2020 - 08:03 AM

Fuse? Not necessarely broken but sometimes the contacts a few corroded. And all the plugs around it, specially the green one if I remember right.
You probably did this already but it's a start until someone els has an idea.

Ben

#3 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 6,986 posts
  • Location: Ballingry, Fife
  • Local Club: TFMOC

Posted 12 January 2020 - 10:02 AM

Fuses or a switch

#4 viz139

viz139

    Mini Mad

  • Members
  • PipPipPipPip
  • 268 posts
  • Location: Ireland
  • Local Club: Irish Mini Owners Club

Posted 12 January 2020 - 11:18 AM

There are no fuses on the headlights on your car although power to the light switch passes through the fuse board ( in and out on the brown wires). Check the two connections on the fuse board and the brown wires on the solenoid . If its not a bad connection its most likely a failed light switch



#5 GordonS

GordonS

    Starting My Mini Up

  • Noobies
  • Pip
  • 3 posts
  • Location: Ayrshire

Posted 12 January 2020 - 03:45 PM

The headlights, brake lights and dash now light up, this was solved by replacing the connector on the wire but the rear lights sidelights and the full beam aren’t working. Do they run off of a different fuse?

#6 viz139

viz139

    Mini Mad

  • Members
  • PipPipPipPip
  • 268 posts
  • Location: Ireland
  • Local Club: Irish Mini Owners Club

Posted 13 January 2020 - 11:19 AM

The dash lights and rear lights are on the same fuse, check the connection beside the wiper motor on the red/green wires.

Do the main beams work on the Flash( pull back the stalk)? if not check the connections on the front slam panel ( blue/white).



#7 GordonS

GordonS

    Starting My Mini Up

  • Noobies
  • Pip
  • 3 posts
  • Location: Ayrshire

Posted 15 January 2020 - 04:02 AM

The issue was a broken piggyback connector that had snapped causing the wire that connects to the fusebox to loose connection, simple fix of stripping the wire slightly and crimping on a new connector




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares