Jump to content


Photo
- - - - -

Aldon Ignitor Kit


  • Please log in to reply
5 replies to this topic

#1 Minigman

Minigman

    Speeding Along Now

  • TMF+ Member
  • PipPipPipPipPip
  • 461 posts
  • Location: Barnstaple

Posted 13 January 2020 - 05:21 PM

Does anyone know if this Pertronix (LU143A) ignitor is the same as the Aldon LU143A?

It’s from the US but nearly half the price of the Aldon hence the question.

Are Aldon and Pertronix the same company?

https://rover.ebay.c...tm/202314868782

Edited by Minigman, 13 January 2020 - 05:29 PM.


#2 leyland73

leyland73

    Mini Mad

  • TMF+ Member
  • PipPipPipPip
  • 124 posts
  • Location: belfast

Posted 14 January 2020 - 09:55 PM

I believe they are they same, hopefully someone else will be along soon who can confirm the same, have Aldon ignitors on all my minis, great stuff. One kit was fitted 20+ years ago and still going strong.

Edited by leyland73, 14 January 2020 - 09:55 PM.


#3 Minigman

Minigman

    Speeding Along Now

  • TMF+ Member
  • PipPipPipPipPip
  • 461 posts
  • Location: Barnstaple

Posted 14 January 2020 - 10:30 PM

They are the same I’ve discovered.

I was particularly curious why anything marked up as Pertronix is half the price of Aldon stuff.

I’ve also been told to buy the Ignitor 2 instead of the Ignitor 1 as they burn out apparently should the ignition be left on for more than a minute.

Think I might go down the Swiftune CSI route.

#4 Turbo Phil

Turbo Phil

    Up Into Fourth

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPip
  • 2,154 posts
  • Location: Cumbria
  • Local Club: Cumbria Classic Mini Club

Posted 14 January 2020 - 11:31 PM

I had one about 18 years ago that burnt out as the ignition was left on. I fitted another and it was fine as I made sure I never made the same mistake again.

Phil.

#5 Minigman

Minigman

    Speeding Along Now

  • TMF+ Member
  • PipPipPipPipPip
  • 461 posts
  • Location: Barnstaple

Posted 15 January 2020 - 08:20 AM

I had one about 18 years ago that burnt out as the ignition was left on. I fitted another and it was fine as I made sure I never made the same mistake again.

Phil.


Do you have any experience with the CSI kit Phil?

#6 Turbo Phil

Turbo Phil

    Up Into Fourth

  • TMF+ Member
  • PipPipPipPipPipPipPipPipPip
  • 2,154 posts
  • Location: Cumbria
  • Local Club: Cumbria Classic Mini Club

Posted 15 January 2020 - 12:50 PM

I had one about 18 years ago that burnt out as the ignition was left on. I fitted another and it was fine as I made sure I never made the same mistake again.

Phil.


Do you have any experience with the CSI kit Phil?

I don’t, sorry.

Phil.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares