Jump to content


Photo
- - - - -

Weird Elec Issue


  • Please log in to reply
5 replies to this topic

#1 28hodge

28hodge

    Mini Mad

  • TMF+ Member
  • PipPipPipPip
  • 212 posts
  • Location: North

Posted 24 July 2020 - 05:43 PM

Ive got an odd issue that I cannot trace. and makes zero sense to me, but im not great with electrics.

 

When i press the horn on the stalk the horn does not work, however the dash binnacle lights come on and the binnacle indicator lights, light up. the indicators themselves do not come on but the light to indicate that you are erm indicating comes on within the dash?

 

the lights all work fine on both side dipped and main beam the indicators all work fine and the horn has 12v to it and works when attached to a battery separately, looking at the wiring diagram i cannot understand how pressing the horn can cause the issue it is.

 

the car is a 1972 clubman with the std 4 fuse block on the inner wing.

 

I have also lost the brake lights but i think this is a duff pressure switch though wont rule out it being connected.

 

anybody point me in the right direct to start to look at, i can prob unplug the connector from the column and remove the horn pin and wire it seperately to see if that solves it but i really cannot understand how the horn being pressed can cause the issue it is.

 

any help please.

 

thanks. 



#2 I hate Brian

I hate Brian

    Super Mini Mad

  • TMF+ Member
  • PipPipPipPipPipPip
  • 507 posts
  • Location: nottingham

Posted 24 July 2020 - 05:49 PM

Possible bad earth somewhere and back feeding ? have you checked this 



#3 28hodge

28hodge

    Mini Mad

  • TMF+ Member
  • PipPipPipPip
  • 212 posts
  • Location: North

Posted 24 July 2020 - 05:59 PM

I have but i'll double check, just been searching the forum now and it was the cause of a similar problem for someone else so I'll head out and clean up the earths and see if that helps things



#4 adam thirty

adam thirty

    Learner Driver

  • Noobies
  • PipPip
  • 21 posts

Posted 24 July 2020 - 07:27 PM

Yeh like above says check the horn earth, if the horn has a good supply voltage and works when powered up with a battery it can only be the earth

#5 cal844

cal844

    Crazy About Mini's

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 7,679 posts
  • Location: Ballingry, Fife
  • Local Club: TFMOC

Posted 24 July 2020 - 07:45 PM

Make sure the earth and live connections are good and that the earth loop is still attached between PU/BK and BK

#6 28hodge

28hodge

    Mini Mad

  • TMF+ Member
  • PipPipPipPip
  • 212 posts
  • Location: North

Posted 25 July 2020 - 08:56 AM

Sorted, was a bad earth, thanks




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares