Jump to content


Photo
- - - - -

mini has broken down AGAIN!!


  • Please log in to reply
4 replies to this topic

#1 P91MER

P91MER

    Ring Runner 2005

  • Members
  • PipPipPipPipPipPipPip
  • 829 posts

Posted 29 October 2004 - 06:50 PM

i was driving on my way home with a mate, just been to get some servicing bits for my mini, new sparks etc when i lost all power..

the car was really struggling, so i took it onto the pavement, where it died!

first thoughts were petrol, but topped it up and nothing.

It is definately something to do with the injection unit, i can get the engine to run, but i have to pulse/keep pressing the accelerator loadsa times for the revs to rise, but as soon as i put my foot down the engine just dies, as though there is no fuel getting into the engine..

I would do the process of elimination, but there is that many components to the injection unit, that it would be cheaper just to buy a whole new unit!

i taken the injectors off and given them a clean, but i have split one of the rubers now, and rover has had to order them in, they are comin on tuesday. but i don't think it is the injectors, as they seem to be in good condition.

it is a MPI, 33K miles.

any ideas?

Rich

#2 NightfireRed Mayfair

NightfireRed Mayfair

    On The Road

  • Noobies
  • PipPip
  • 35 posts

Posted 29 October 2004 - 07:03 PM

it could be possible that you fuel pump has died or has got clogged with debris from the fuel tank, but i'm not 100% certain though.

#3 P91MER

P91MER

    Ring Runner 2005

  • Members
  • PipPipPipPipPipPipPip
  • 829 posts

Posted 29 October 2004 - 07:20 PM

you can always hear the inj fuel pump, as it lets off a real high pitch noise, and if you have your head in the boot, you can still hear it loud and clear!

I thought fuel filter? there is still fuel at the inj unit end odviously, but just prob not enough!

If not, if it had a dodgey vacuum pump, or inj valve, would that course a similar problem?

I have had the car about 18 months, and have never changed the fuel filter, i don't know about the previous owner tho.

Rich

#4 Mincento

Mincento

    Speeding Along Now

  • Members
  • PipPipPipPipPip
  • 443 posts

Posted 29 October 2004 - 10:23 PM

i had the same problem with my fiat cinq spi and just got it home and started it up next problem and it work perfect now

#5 Guess-Works.com

Guess-Works.com

    Gearbox Guru

  • Traders
  • PipPipPipPipPipPipPipPipPipPipPip
  • 19,824 posts
  • Local Club: Rugby Classic Mini Owners Club

Posted 29 October 2004 - 10:48 PM

Just a thought Rich, you know when you went over that rock, check the fuel lines, and make sure it didn't crimp one... The symptoms point to fuel starvation, and that could be a possibility, a restriction in flow ?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares