Jump to content


Photo
- - - - -

Heater Blowing Cold Even With New Heater

electrical

  • Please log in to reply
6 replies to this topic

#1 Josh_091

Josh_091

    Starting My Mini Up

  • Noobies
  • Pip
  • 2 posts
  • Location: Halifax

Posted 01 February 2020 - 04:33 PM

Hi sorry if this has already been covered but basically my heater isn’t blowing hot air, it’s not freezing cold and it’s warmer than when I have the valve pulled fully out but it’s still not warm enough to heat the car.
I have put in a new heater matrix and a new valve and it doesn’t appear to have helped much however a new radiator has also been recently installed so not sure if this would effect how hot the heater gets.

Any help is much appreciated thanks

#2 Ethel

Ethel

    ..is NOT a girl!

  • TMF Team
  • PipPipPipPipPipPipPipPipPipPipPip
  • 23,218 posts
  • Local Club: none

Posted 01 February 2020 - 04:45 PM

Valve on the head or the remote type?

 

Easiest thing to check is if the thermostat is working - does the top hose get warm as soon as the temp gauge moves?



#3 phillrulz

phillrulz

    Super Mini Mad

  • TMF+ Member
  • PipPipPipPipPipPip
  • 572 posts
  • Location: North West London

Posted 01 February 2020 - 05:22 PM

Could be airlock , and most minis need more than idle revs to pump water through the heater 



#4 Quinlan minor

Quinlan minor

    Stage One Kit Fitted

  • Noobies
  • PipPipPip
  • 63 posts
  • Location: London
  • Local Club: LSMOC

Posted 01 February 2020 - 05:53 PM

Check the hoses to and from the heater, the one ‘to’ will warm soonest. Disconnect the 'from' and backfill the pipe with a watering can, or similar. That should solve an airlock.


Edited by Quinlan minor, 02 February 2020 - 12:13 PM.


#5 Rorf

Rorf

    One Carb Or Two?

  • Members
  • PipPipPipPipPipPipPip
  • 791 posts
  • Location: Cape Town

Posted 02 February 2020 - 10:24 AM

Check that the thermostat is working correctly.



#6 Twincam

Twincam

    Camshaft & Stage Two Head

  • TMF+ Member
  • PipPipPipPipPipPipPipPip
  • 1,731 posts
  • Location: Londinium
  • Local Club: SMAG

Posted 02 February 2020 - 11:36 AM

Is the valve opening fully also?

#7 Josh_091

Josh_091

    Starting My Mini Up

  • Noobies
  • Pip
  • 2 posts
  • Location: Halifax

Posted 04 February 2020 - 01:59 PM

Hi sorry to get back late but just checked the pipe and wasn’t much water in it so I think it may have been an airlock, thanks for the replies everyone





Also tagged with one or more of these keywords: electrical

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Mini Spares